OpenEdv-开源电子网

 找回密码
 立即注册

扫一扫,访问微社区

正点原子新作:阿波罗STM32F767&F429&探索者STM32F4开发板&赶快来下载资料哦。

查看: 290|回复: 4

sx1278 发送失败

[复制链接]

  离线 

3

主题

5

帖子

0

精华

新手上路

Rank: 1

积分
43
金钱
43
注册时间
2015-9-5
在线时间
6 小时
发表于 2017-5-4 15:47:06 | 显示全部楼层 |阅读模式
1金钱
下面是SPI 发送函数

uint8_t SpiInOut( uint8_t outData )
{
        uint8_t lmGET_data;

        HAL_SPI_TransmitReceive(&hspi1, &outData, &lmGET_data, 1, SPI_TIMEOUT);

        return lmGET_data;
}   

下面检测DIO引脚,一直不能置位,各位大神有遇到么?
    case RFLR_STATE_TX_RUNNING:
        if( DIO0 == 1 ) // TxDone
        {
            // Clear Irq
            SX1276Write( REG_LR_IRQFLAGS, RFLR_IRQFLAGS_TXDONE  );
            RFLRState = RFLR_STATE_TX_DONE;   
        }

回复

使用道具 举报

  离线 

2

主题

51

帖子

0

精华

初级会员

Rank: 2

积分
133
金钱
133
注册时间
2017-5-4
在线时间
11 小时
发表于 2017-5-4 17:25:21 | 显示全部楼层
我这边调试sx1276,SPI接口的MISO一直都是0,硬件上那几个DIO引脚,我就接了DIO0,其他的都没接,楼主知道这是什么情况吗?望指教,谢谢
回复

使用道具 举报

  离线 

482

主题

8万

帖子

30

精华

管理员

Rank: 12Rank: 12Rank: 12

积分
117015
金钱
117015
注册时间
2010-12-1
在线时间
896 小时
发表于 2017-5-4 19:07:26 | 显示全部楼层
帮顶
回复

使用道具 举报

  离线 

2

主题

51

帖子

0

精华

初级会员

Rank: 2

积分
133
金钱
133
注册时间
2017-5-4
在线时间
11 小时
发表于 2017-5-8 23:03:38 | 显示全部楼层
楼主你这里的SPI用的是硬件还是软件,我之前调试sx1276,SPI的数据一直不正常,后来发现是因为SPI的片选拉低后没有拉高,导致SPI被我锁死了,但是使用软件的SPI根据手册模拟波形,芯片才正常工作,发送端发送完以后DIO0引脚就会产生一个上升沿中断,可惜我的接收端一直收不到数据,很郁闷不知道是什么情况,你这个没有中断会不会就是因为SPI的片选信号没有释放导致的呢?
回复

使用道具 举报

  离线 

2

主题

51

帖子

0

精华

初级会员

Rank: 2

积分
133
金钱
133
注册时间
2017-5-4
在线时间
11 小时
发表于 2017-5-10 10:20:05 | 显示全部楼层
我这边已经调通了sx1276,建议你不要用硬件SPI了,使用软件SPI吧,发送时序要严格按照手册来,我前面遇到的问题基本上都是时序和手册上不太一样导致的,祝好运
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则




QQ|联系我们|手机版|官方淘宝店|新浪微博|微信公众平台|OpenEdv-开源电子网 ( 粤ICP备12000418号-1 )

GMT+8, 2017-11-18 16:21

Powered by OpenEdv-开源电子网

© 2001-2030 OpenEdv-开源电子网

快速回复 返回顶部 返回列表
/* */