OpenEdv-开源电子网

 找回密码
 立即注册

扫一扫,访问微社区

正点原子新作:阿波罗STM32F767&F429&探索者STM32F4开发板&赶快来下载资料哦。

查看: 202|回复: 9

晶振不起振?求大神指导,不胜感激!

[复制链接]

  离线 

12

主题

30

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
244
金钱
244
注册时间
2017-3-28
在线时间
53 小时
发表于 7 天前 | 显示全部楼层 |阅读模式
5金钱
        之前做了10块样板(嘉立创打样),用了PSOC的BLE4.0的蓝牙芯片,自带Cortex m0内核,十块样板都能正常工作。接下来小批量做了一批板子(以前经常合作的制板厂),都出现了一个问题,外部的32.768K的晶体不起振,这是奇怪的问题出现了,用热风枪对着芯片晶振周围吹一段时间,晶振起振了,功能也都没有问题,过了半小时,板子的温度降到常温了,还是没有问题,每过段时间测一下,都没有问题,一切正常,再过一段时间(大概从风枪吹过后一个半小时),所有的板子又都不正常了,还是晶振不起振。于是我又用热风枪吹了一下,又都好了,这是我们这些好的板子放到冰箱,大概20分钟后拿出来,所有的板子上晶振又都不起振。有没有大神遇到过类似的情况,求指导?

回复

使用道具 举报

  离线 

1

主题

327

帖子

0

精华

高级会员

Rank: 4

积分
823
金钱
823
注册时间
2011-12-1
在线时间
61 小时
发表于 7 天前 | 显示全部楼层
用恒温晶振代替普通晶振,有些晶振到了温度低的时候容易出问题。
回复

使用道具 举报

  离线 

12

主题

30

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
244
金钱
244
注册时间
2017-3-28
在线时间
53 小时
 楼主| 发表于 7 天前 | 显示全部楼层
xlong_06 发表于 2017-11-15 09:29
用恒温晶振代替普通晶振,有些晶振到了温度低的时候容易出问题。

我有把晶振拆下来,焊到之前的打样板子上,可以正常工作的,应该不是晶振的问题。也换过其他类型晶振(圆柱型的),还是会出现同样的问题。现在感觉是板子的问题,但是又找不出原因,还好这次是小批量,就600套,没找出原因之前也不敢再打板
回复

使用道具 举报

  离线 

2

主题

8

帖子

0

精华

初级会员

Rank: 2

积分
178
金钱
178
注册时间
2017-8-21
在线时间
22 小时
发表于 7 天前 | 显示全部楼层
样板有没有经过高低温测试?把样板放进冰箱温度降低后是不是也有相同的问题??
回复

使用道具 举报

  离线 

12

主题

30

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
244
金钱
244
注册时间
2017-3-28
在线时间
53 小时
 楼主| 发表于 7 天前 | 显示全部楼层
良性循环 发表于 2017-11-15 12:38
样板有没有经过高低温测试?把样板放进冰箱温度降低后是不是也有相同的问题??

之前放到冰箱里就有样板,样板能正常工作,没有问题。你也遇到过类似的问题吗?
回复

使用道具 举报

  离线 

2

主题

8

帖子

0

精华

初级会员

Rank: 2

积分
178
金钱
178
注册时间
2017-8-21
在线时间
22 小时
发表于 7 天前 | 显示全部楼层
样板和批量生产的板子完全一模一样?走线,基材,生产环境完全一样吗?
我没遇到过类似的问题,只是很想知道产生问题的原因,所以帮忙想想可能产生的原因!
回复

使用道具 举报

  离线 

12

主题

30

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
244
金钱
244
注册时间
2017-3-28
在线时间
53 小时
 楼主| 发表于 7 天前 | 显示全部楼层
良性循环 发表于 2017-11-15 13:40
样板和批量生产的板子完全一模一样?走线,基材,生产环境完全一样吗?
我没遇到过类似的问题,只是很想知 ...

样板和批量生产的板子不是在同一个厂家生产的,但是是同一个Gerber文件。我检查过两种板子的电气特性,都没有问题,基材应该都是FR4,叠层结构可能有差异。但是我个人感觉这个影响应该很小吧,而且晶振的匹配电容我也在调了很多范围。目前还不知道是什么原因,还在努力排查,一旦有结果我会立马回帖的。
回复

使用道具 举报

  离线 

2

主题

8

帖子

0

精华

初级会员

Rank: 2

积分
178
金钱
178
注册时间
2017-8-21
在线时间
22 小时
发表于 6 天前 来自手机 | 显示全部楼层
顺便问下板子有没有做三防处理?我们遇到过三防处理后影响晶振起振的!
回复

使用道具 举报

  离线 

12

主题

30

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
244
金钱
244
注册时间
2017-3-28
在线时间
53 小时
 楼主| 发表于 6 天前 | 显示全部楼层
良性循环 发表于 2017-11-16 09:09
顺便问下板子有没有做三防处理?我们遇到过三防处理后影响晶振起振的!

问题已经解决了,应该是洗板水或者助焊剂的问题。把板子上的器件拆了后量晶振焊盘的电容值达到了好几百pF,这是拿热风枪吹一下,再量晶振焊盘电容值,差不多2pF左右,这是就是正常值,过一个多小时后再量晶振焊盘电容值又到几百pF,又不正常了。接下来用我们自己可靠的洗板水再在板子上擦一遍,电容值正常了,到现在为止已经快一天了,目前还没有出现问题。板子上也没有其他东西(没涂三防漆),所以说应该是贴片厂的洗板水或助焊剂的问题。
回复

使用道具 举报

  离线 

2

主题

8

帖子

0

精华

初级会员

Rank: 2

积分
178
金钱
178
注册时间
2017-8-21
在线时间
22 小时
发表于 6 天前 | 显示全部楼层
那是洗板水或者助焊剂有残留,导致电容值不稳定,用你们自己的清洗剂洗过后就排除问题了,这样想能说的通!那得注意一下他们厂里用的是什么型号的清洗剂,下次不能再用。
如果问题真的是这样的话,在正常的板子上用他原来出问题的助焊剂或洗板水重新在好的板子上涂一遍,问题是否能够重现???
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则




QQ|联系我们|手机版|官方淘宝店|新浪微博|微信公众平台|OpenEdv-开源电子网 ( 粤ICP备12000418号-1 )

GMT+8, 2017-11-22 03:35

Powered by OpenEdv-开源电子网

© 2001-2030 OpenEdv-开源电子网

快速回复 返回顶部 返回列表
/* */