OpenEdv-开源电子网

 找回密码
 立即注册

扫一扫,访问微社区

正点原子全套STM32开发资料,上千讲STM32视频教程,RT1052教程免费下载啦...
查看: 870|回复: 9

串口波特率问题

[复制链接]

  离线 

2

主题

5

帖子

0

精华

新手上路

积分
22
金钱
22
注册时间
2018-2-9
在线时间
1 小时
发表于 2018-2-9 21:10:56 | 显示全部楼层 |阅读模式
1金钱
本帖最后由 星星笑了 于 2018-2-9 21:12 编辑

在串口程序中设置波特率为115200,但是用调试助手波特率必须设置成38400才可以运行,在例程模板中没有这样的问题,同样的函数在自己写的模板中就会出现上述问题,这个问题应该怎么解决?

5NR736P)[FX`A263G@EBG`8.png
回复

使用道具 举报

  离线 

9

主题

1348

帖子

0

精华

论坛元老

Rank: 8Rank: 8

积分
4979
金钱
4979
注册时间
2013-3-8
在线时间
669 小时
发表于 2018-2-10 11:05:24 | 显示全部楼层
会不会有其他地方设置了你没看到。或PLL设置错误
回复

使用道具 举报

  离线 

6

主题

25

帖子

0

精华

初级会员

Rank: 2

积分
71
金钱
71
注册时间
2018-1-21
在线时间
13 小时
发表于 2018-2-10 16:05:08 | 显示全部楼层
按理说串口程序中设置波特率为115200,串口调试助手波特率也设置成115200就可以运行了啊。你确定下你程序中的波特率设定呢?
回复

使用道具 举报

  离线 

5

主题

441

帖子

0

精华

高级会员

Rank: 4

积分
815
金钱
815
注册时间
2017-12-15
在线时间
98 小时
发表于 2018-2-10 16:26:03 | 显示全部楼层
1152000=3*38400

可能是因为,虽然串口部分设置的相同,但是,你的系统时钟是例程中运行平台的三分之一。
回复

使用道具 举报

  离线 

2

主题

5

帖子

0

精华

新手上路

积分
22
金钱
22
注册时间
2018-2-9
在线时间
1 小时
 楼主| 发表于 2018-2-10 22:45:20 | 显示全部楼层
augustedward 发表于 2018-2-10 11:05
会不会有其他地方设置了你没看到。或PLL设置错误

还是没有找到原因,但是谢谢您的回答
回复

使用道具 举报

  离线 

2

主题

5

帖子

0

精华

新手上路

积分
22
金钱
22
注册时间
2018-2-9
在线时间
1 小时
 楼主| 发表于 2018-2-10 22:45:35 | 显示全部楼层
为梦而生jcm 发表于 2018-2-10 16:05
按理说串口程序中设置波特率为115200,串口调试助手波特率也设置成115200就可以运行了啊。你确定下你程序中 ...

还是没有找到原因,但是谢谢您的回答
回复

使用道具 举报

  离线 

2

主题

5

帖子

0

精华

新手上路

积分
22
金钱
22
注册时间
2018-2-9
在线时间
1 小时
 楼主| 发表于 2018-2-10 22:45:48 | 显示全部楼层
a496298685 发表于 2018-2-10 16:26
1152000=3*38400

可能是因为,虽然串口部分设置的相同,但是,你的系统时钟是例程中运行平台的三分之一 ...

还是没有找到原因,但是谢谢您的回答
回复

使用道具 举报

  离线 

7

主题

14

帖子

0

精华

初级会员

Rank: 2

积分
81
金钱
81
注册时间
2018-4-18
在线时间
8 小时
发表于 2018-5-29 20:33:47 | 显示全部楼层
你炸到原因可吗?我今天也是这个问题
回复

使用道具 举报

  离线 

0

主题

1

帖子

0

精华

新手上路

积分
32
金钱
32
注册时间
2018-1-16
在线时间
7 小时
发表于 2018-5-30 16:32:24 | 显示全部楼层
可能是你的晶振没有配好,在stm32f4xx.h文件中要把HSE_VALUE 配置成你的外部晶振值。可以试试
回复

使用道具 举报

  离线 

7

主题

14

帖子

0

精华

初级会员

Rank: 2

积分
81
金钱
81
注册时间
2018-4-18
在线时间
8 小时
发表于 2018-5-31 10:22:45 | 显示全部楼层
csyfujian 发表于 2018-5-30 16:32
可能是你的晶振没有配好,在stm32f4xx.h文件中要把HSE_VALUE 配置成你的外部晶振值。可以试试

那你帮忙看下我的帖子吗?我的也是这种错误,可是我用寄存器版本的!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则




关闭

报名原子哥新品发布会&粉丝见面会上一条 /1 下一条

正点原子公众号

QQ|联系我们|手机版|官方淘宝店|微信公众平台|OpenEdv-开源电子网 ( 粤ICP备12000418号-1 )

GMT+8, 2018-10-18 15:33

Powered by OpenEdv-开源电子网

© 2001-2030 OpenEdv-开源电子网

快速回复 返回顶部 返回列表
/* */