OpenEdv-开源电子网

 找回密码
 立即注册

扫一扫,访问微社区

正点原子新作:阿波罗STM32F767&F429&探索者STM32F4开发板&赶快来下载资料哦。

查看: 132|回复: 5

FreeRTOS队列实验纠错

[复制链接]

  离线 

7

主题

416

帖子

0

精华

金牌会员

Rank: 6Rank: 6

积分
1077
金钱
1077
注册时间
2015-8-25
在线时间
169 小时
发表于 2018-5-29 13:34:19 | 显示全部楼层 |阅读模式
正点原子公众号
原子哥,图中圈出的位置,您的工程中num未初始化,实验过程中LCD用不同颜色刷屏时顺序不对,应该将num初始化为0,按照颜色数组中的顺序刷屏
111.jpg
回复

使用道具 举报

  离线 

65

主题

6451

帖子

5

精华

资深版主

Rank: 8Rank: 8

积分
12866
金钱
12866
注册时间
2013-11-13
在线时间
1450 小时
发表于 2018-5-29 14:59:34 | 显示全部楼层
嗯,多谢纠错
回复 支持 反对

使用道具 举报

  离线 

7

主题

416

帖子

0

精华

金牌会员

Rank: 6Rank: 6

积分
1077
金钱
1077
注册时间
2015-8-25
在线时间
169 小时
 楼主| 发表于 2018-5-29 16:55:13 | 显示全部楼层
用的F407探索者,标准库,实验现象为:程序开始,第一次按下KEY0,num++应该为1,LCD应该填充颜色lcd_discolor[num%14]即lcd_discolor[1]即BLACK黑色,但是我的板子上不是黑色,而是需要按下几次好才开始从颜色数组开始刷屏,也就是说程序一开始num初始化不为0导致的实验现象不对,在修改num初始化为0后按照设计按下KEY0后LCD按照颜色数组里的颜色刷屏。
回复 支持 反对

使用道具 举报

  离线 

0

主题

5

帖子

0

精华

新手上路

积分
20
金钱
20
注册时间
2018-5-24
在线时间
2 小时
发表于 2018-5-30 09:07:15 | 显示全部楼层
点错了,是点赞收藏,尴尬!
回复 支持 反对

使用道具 举报

  离线 

7

主题

416

帖子

0

精华

金牌会员

Rank: 6Rank: 6

积分
1077
金钱
1077
注册时间
2015-8-25
在线时间
169 小时
 楼主| 发表于 2018-5-30 10:20:02 | 显示全部楼层
正点原子公众号

用串口看过了,num不初始化为0的时候这个值很大的负数,执行完第一次num++后为166,好几个后面的工程里的num都没执行初始化,用颜色数组刷LCD屏幕时都有这个问题,实验相象都一样的:LCD刷屏的颜色不是从颜色数组【1%14】开始,而是从【166%14】开始的,不影响功能。
回复 支持 反对

使用道具 举报

  离线 

65

主题

6451

帖子

5

精华

资深版主

Rank: 8Rank: 8

积分
12866
金钱
12866
注册时间
2013-11-13
在线时间
1450 小时
发表于 2018-5-30 10:23:06 | 显示全部楼层
szczyb1314 发表于 2018-5-30 10:20
用串口看过了,num不初始化为0的时候这个值很大的负数,执行完第一次num++后为166,好几个后面的工程里的 ...

对的,不管是全局变量还是局部变量,都是要做初始化的
开往春天的手扶拖拉机
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则




QQ|联系我们|手机版|官方淘宝店|新浪微博|微信公众平台|OpenEdv-开源电子网 ( 粤ICP备12000418号-1 )

GMT+8, 2018-6-22 07:49

Powered by OpenEdv-开源电子网

© 2001-2030 OpenEdv-开源电子网

快速回复 返回顶部 返回列表
/* */