OpenEdv-开源电子网

 找回密码
 立即注册

扫一扫,访问微社区

正点原子全套STM32开发资料,上千讲STM32视频教程,RT1052教程免费下载啦...

查看: 5786|回复: 6

灰尘传感器GP2Y1010AU0F使用心得

[复制链接]

  离线 

4

主题

5

帖子

0

精华

新手上路

积分
41
金钱
41
注册时间
2014-12-24
在线时间
0 小时
发表于 2015-4-21 09:10:14 | 显示全部楼层 |阅读模式
正点原子公众号
最近在网上买了一个GP2Y1010AU0F灰尘传感器,打算自己试试,按照使用手册搭了一个电路,电路如下图所示:


我用的C8051F单片机,没有加那个Q1 NPN 三极管,直接把这个LED口设置成漏极开漏了,因为我用的单片机也是3.3V,所以输出口VO,通过两个电阻分压后才给的单片机的AD采集口

2、写好程序,在示波器上能看到电平的变化



于是用的是AD采集红线,也就是输出的电压值

3、根据手册上,输出电压与PM2.5的关系曲线如下图所示:



4、我实际测试的是通过香烟烟雾,给他吐一口烟,趋势能够看到输出电压的变化,AD采集最大能到1.7V左右,对应的对应的实际VO大概是3.4V了(分压电阻都是10K,所以AD采集的是Vo/2),只是按照上面曲线的描述,在灰尘浓度是0的时候,VO应该输出接近1V,但是我这个为什么平常状态,也就是室内,不给他吐烟时,输出一直是0V,我看论坛里不少兄弟也用过,所以把自己的经验也分享出来,也问问有没有跟我遇到一样的问题的?

回复

使用道具 举报

  离线 

5

主题

9

帖子

0

精华

新手上路

积分
49
金钱
49
注册时间
2015-5-6
在线时间
0 小时
发表于 2015-5-6 22:08:18 | 显示全部楼层
楼主你是怎么把采集的电压转换成空气质量指数的,用的什么函数?
回复 支持 反对

使用道具 举报

  离线 

0

主题

37

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
495
金钱
495
注册时间
2017-4-14
在线时间
55 小时
发表于 2017-6-10 14:32:20 | 显示全部楼层
我也遇到同样问题 不用三极,直接在IO口上是才1.7V, 接了三极只有0.4V最大
回复 支持 反对

使用道具 举报

  离线 

0

主题

37

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
495
金钱
495
注册时间
2017-4-14
在线时间
55 小时
发表于 2017-6-10 14:51:16 | 显示全部楼层
QQ图片20170610145010.jpg
QQ图片20170610145015.jpg
QQ图片20170610145020.jpg
回复 支持 反对

使用道具 举报

  离线 

0

主题

37

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
495
金钱
495
注册时间
2017-4-14
在线时间
55 小时
发表于 2017-6-12 09:36:30 | 显示全部楼层
正点原子公众号
找出问题了,给GP2Y1010AU0F供电是7V时,其它的不变,VO输出就有4V
回复 支持 反对

使用道具 举报

  离线 

6

主题

104

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
448
金钱
448
注册时间
2017-2-11
在线时间
60 小时
发表于 2017-7-26 15:16:45 | 显示全部楼层
6666
回复 支持 反对

使用道具 举报

  离线 

1

主题

6

帖子

0

精华

新手上路

积分
32
金钱
32
注册时间
2018-3-29
在线时间
3 小时
发表于 2018-3-30 19:36:13 | 显示全部楼层
兄弟,传感器接线没问题,程序也应该没问题,但是没输出是怎么回事呢?
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则




关闭

必看:"原子哥”力荐上一条 /1 下一条

QQ|联系我们|手机版|官方淘宝店|微信公众平台|OpenEdv-开源电子网 ( 粤ICP备12000418号-1 )

GMT+8, 2018-8-20 18:57

Powered by OpenEdv-开源电子网

© 2001-2030 OpenEdv-开源电子网

快速回复 返回顶部 返回列表
/* */