OpenEdv-开源电子网

 找回密码
 立即注册

扫一扫,访问微社区

正点原子新作:阿波罗STM32F767&F429&探索者STM32F4开发板&赶快来下载资料哦。

查看: 2305|回复: 12

这是Keil的BUG吗?

[复制链接]

  离线 

2

主题

6

帖子

0

精华

初级会员

Rank: 2

积分
98
金钱
98
注册时间
2015-8-17
在线时间
12 小时
发表于 2016-4-20 21:18:47 | 显示全部楼层 |阅读模式
1金钱
本帖最后由 郭佳佳 于 2016-4-20 21:29 编辑

最近一段时间在学emwin,今天搞XBF字体,涉及到了一些编码问题!貌似是Keil的BUG(用的是Keil5.14)
如图所示:
如果解除注释部分,会出现以下编译错误:
*** Using Compiler 'V5.05 update 1 (build 106)', folder: 'C:\Keil_v5\ARM\ARMCC\Bin'
Build target 'Target 1'
compiling Font_CN.c...
App\Font_CN.c(57): error:  #8: missing closing quote
        GUI_DispStringHCenterAt("鐧戒簯娣卞?鏈変汉瀹躲
QQ截图20160420211037.png
QQ截图20160420212131.png

最佳答案

查看完整内容[请看2#楼]

要显示汉字的文件重新将编码方式改为UTF-8。即使你以前已经改了,现在也要重新在改一次。只要有这种error提示就要改一次
回复

使用道具 举报

  离线 

60

主题

6269

帖子

5

精华

资深版主

Rank: 8Rank: 8

积分
12385
金钱
12385
注册时间
2013-11-13
在线时间
1389 小时
发表于 2016-4-20 21:18:48 | 显示全部楼层
要显示汉字的文件重新将编码方式改为UTF-8。即使你以前已经改了,现在也要重新在改一次。只要有这种error提示就要改一次
回复

使用道具 举报

  离线 

2

主题

6

帖子

0

精华

初级会员

Rank: 2

积分
98
金钱
98
注册时间
2015-8-17
在线时间
12 小时
 楼主| 发表于 2016-4-21 07:27:49 | 显示全部楼层
zuozhongkai 发表于 2016-4-20 21:18
要显示汉字的文件重新将编码方式改为UTF-8。即使你以前已经改了,现在也要重新在改一次。只要有这种error提 ...

谢谢版主,按照你说的,我每次改动含中文字体的.c文件,都用记事本将这个.c文件覆盖另存为UTF-8编码!问题解决了!难道就没有其他更好的解决方案吗?
回复

使用道具 举报

  离线 

15

主题

411

帖子

0

精华

金牌会员

Rank: 6Rank: 6

积分
1064
金钱
1064
注册时间
2014-5-24
在线时间
102 小时
发表于 2016-4-21 09:24:30 | 显示全部楼层
这样可解决,在编译器选项中添加:--locale=english
I See Fire.·.·.·.·.·.·.·.·.·.·.·.·.·.·.·.·.·.·.·.  只给方向,不妨碍思考
回复

使用道具 举报

  离线 

2

主题

6

帖子

0

精华

初级会员

Rank: 2

积分
98
金钱
98
注册时间
2015-8-17
在线时间
12 小时
 楼主| 发表于 2016-4-22 07:23:56 来自手机 | 显示全部楼层
正点原子公众号
emWin 发表于 2016-4-21 09:24
这样可解决,在编译器选项中添加:--locale=english

能具体说一下嘛?
回复

使用道具 举报

  离线 

0

主题

2

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
220
金钱
220
注册时间
2014-5-27
在线时间
6 小时
发表于 2016-6-22 16:21:44 | 显示全部楼层
Options for Target 'Flash' -> C/C++ -> Misc Controls添加“ --locale=english”
回复

使用道具 举报

  离线 

1

主题

5

帖子

0

精华

初级会员

Rank: 2

积分
60
金钱
60
注册时间
2014-8-5
在线时间
7 小时
发表于 2016-7-11 19:48:45 | 显示全部楼层
知其然 发表于 2016-6-22 16:21
Options for Target 'Flash' -> C/C++ -> Misc Controls添加“ --locale=english”

真是大神啊,完美解决这个问题!
回复

使用道具 举报

xckhmf 该用户已被删除
发表于 2016-12-8 14:13:00 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复

使用道具 举报

  离线 

33

主题

92

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
280
金钱
280
注册时间
2013-6-18
在线时间
15 小时
发表于 2017-1-11 15:00:08 来自手机 | 显示全部楼层
膜拜大神
回复

使用道具 举报

  离线 

0

主题

312

帖子

0

精华

高级会员

Rank: 4

积分
743
金钱
743
注册时间
2016-11-25
在线时间
145 小时
发表于 2017-1-11 15:25:40 | 显示全部楼层
膜拜大神
回复

使用道具 举报

  离线 

10

主题

34

帖子

0

精华

中级会员

Rank: 3Rank: 3

积分
223
金钱
223
注册时间
2013-6-27
在线时间
22 小时
发表于 2017-1-16 14:19:21 | 显示全部楼层
膜拜!如果能讲一下为什么,那就更膜拜了
回复

使用道具 举报

  离线 

0

主题

3

帖子

0

精华

初级会员

Rank: 2

积分
194
金钱
194
注册时间
2016-3-10
在线时间
77 小时
发表于 2017-2-22 16:33:29 | 显示全部楼层
高手,mark
回复

使用道具 举报

  离线 

0

主题

1

帖子

0

精华

新手入门

积分
12
金钱
12
注册时间
2018-4-17
在线时间
0 小时
发表于 2018-4-17 16:24:40 | 显示全部楼层
本帖最后由 Jayce 于 2018-4-17 16:25 编辑
zcz0426 发表于 2017-1-16 14:19
膜拜!如果能讲一下为什么,那就更膜拜了
共勉
Syntax
--locale=lang_country
Where:
lang_country
is the new default locale.
Use this option in combination with --multibyte_chars.

Note
If the source file encoding is UTF-8 or UTF-16, and the file starts with a byte order mark then the compiler ignores the --locale and --[no_]multibyte_chars options and interprets the file as UTF-8 or UTF-16.

Example
To compile Japanese source files on an English-based Windows workstation, use:
--multibyte_chars --locale=japanese

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则




QQ|联系我们|手机版|官方淘宝店|新浪微博|微信公众平台|OpenEdv-开源电子网 ( 粤ICP备12000418号-1 )

GMT+8, 2018-4-27 01:20

Powered by OpenEdv-开源电子网

© 2001-2030 OpenEdv-开源电子网

快速回复 返回顶部 返回列表
/* */