OpenEdv-开源电子网

 找回密码
 立即注册

扫一扫,访问微社区

正点原子新作:阿波罗STM32F767&F429&探索者STM32F4开发板&赶快来下载资料哦。

查看: 249|回复: 5

使用VP230做can收发器,发现可以接收但不可发送,TJA1050则可以。

[复制链接]

  离线 

1

主题

2

帖子

0

精华

新手上路

Rank: 1

积分
10
金钱
10
注册时间
2016-11-27
在线时间
1 小时
发表于 2016-11-27 10:42:46 | 显示全部楼层 |阅读模式
1金钱
具体情况是我有两套板子,一套是F103+VP230,一套是F407+TJA1050。(我想我遇到的问题和MCU应该无关)
这两套板子分别和我的USB-CAN设备通讯没有问题,收发都妥妥的。
但是当我连上汽车的CAN总线时,F407+TJA1050收发通讯没有问题。
而F103+VP230接收非常的顺畅,但发送就一直不行,永远没法进入CAN_IT_TME中断。
我加了个CAN1_SCE_IRQHandler观察,结果果然被CAN1_SCE_IRQHandler中断俘获了,CAN_GetITStatus了一下发现是CAN_IT_ERR中断。
网上大概查了查,VP230是3.3供电的,TJA1050是5V供电了,有人说有可能是这样的问题。
按说CAN是看差分电压差的,不管给VP230供3.3还是5v,发送时最大压差都是2.2V左右,只是隐形电平3.3v供电时是1.7V,而5V供电时是2.5V(和TJA1050一样)左右。
请问实际应用上是否有这样的问题?还有就是VP230长期5V供电有没有问题(毕竟DATASHEET上看是3.3V供电的设备)?真是这问题的话我就改改板子或者把VCC管脚掰直了不接触焊盘直接焊根线去5v。
多谢有经验的前辈指点!

回复

使用道具 举报

  离线 

485

主题

8万

帖子

30

精华

管理员

Rank: 12Rank: 12Rank: 12

积分
118299
金钱
118299
注册时间
2010-12-1
在线时间
923 小时
发表于 2016-11-27 11:39:49 | 显示全部楼层
回复

使用道具 举报

  离线 

1

主题

2

帖子

0

精华

新手上路

Rank: 1

积分
10
金钱
10
注册时间
2016-11-27
在线时间
1 小时
 楼主| 发表于 2016-11-27 12:24:40 | 显示全部楼层
我又测了一下,隐形电平是1.5V,我的USB CAN是2.0V,和隐形电平有关吗?车上时共地的。用USB CAN是不共地的,是因为这个嘛?
回复

使用道具 举报

  离线 

3

主题

18

帖子

0

精华

新手上路

Rank: 1

积分
40
金钱
40
注册时间
2016-3-10
在线时间
11 小时
发表于 2016-12-25 01:43:51 | 显示全部楼层
我用的也是VP230,3.3V供电,隐性电平 没有这么低,大概2.1-2.2V 左右。你的1.7V的确太低了,这样的话差分电平肯定是不达标的,信号发出的时候肯定有错误。
是不是硬件设计问题,有器件拉低了电平?你直接给VP230上3.3V电,CANH和GND之间的默认电平肯定不会有这么低。
回复

使用道具 举报

  离线 

1

主题

3

帖子

0

精华

新手上路

Rank: 1

积分
24
金钱
24
注册时间
2017-11-30
在线时间
4 小时
发表于 2017-12-7 21:16:37 | 显示全部楼层
vp230   ref引脚接什么?不接会有影响吗?
回复

使用道具 举报

  离线 

2

主题

27

帖子

0

精华

初级会员

Rank: 2

积分
117
金钱
117
注册时间
2014-1-28
在线时间
17 小时
发表于 7 天前 | 显示全部楼层
要接4.7K电阻,不能空着1!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则




QQ|联系我们|手机版|官方淘宝店|新浪微博|微信公众平台|OpenEdv-开源电子网 ( 粤ICP备12000418号-1 )

GMT+8, 2017-12-15 20:21

Powered by OpenEdv-开源电子网

© 2001-2030 OpenEdv-开源电子网

快速回复 返回顶部 返回列表
/* */